summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVi0L02017-02-19 16:42:56 +0100
committerVi0L02017-02-19 16:42:56 +0100
commite699a3aa0fc00689c3d0bfa3871e03ecec84e772 (patch)
treeda3ed39385227ec0ce9a12c0704520aa735b6431
parenta4bfde717f99d36301910b5e5f69de7456599ab4 (diff)
downloadaur-e699a3aa0fc00689c3d0bfa3871e03ecec84e772.tar.gz
15.9-7: provides/conflicts additions
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8574c103a3d..dea04e93fda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = catalyst-utils
pkgver = 15.9
- pkgrel = 5
+ pkgrel = 7
url = http://www.amd.com
arch = i686
arch = x86_64
@@ -65,13 +65,17 @@ pkgname = catalyst-libgl
pkgdesc = AMD/ATI drivers. Catalyst drivers libraries symlinks + experimental powerXpress support.
install = catalyst-libgl.install
depends = catalyst-utils
- depends = mesa>=10.1.0-4
+ depends = mesa
provides = libgl
provides = mesa-libgl
provides = mesa-libgl-git
+ provides = libgles
+ provides = libegl
conflicts = libgl
conflicts = mesa-libgl
conflicts = mesa-libgl-git
+ conflicts = libgles
+ conflicts = libegl
pkgname = opencl-catalyst
pkgdesc = AMD/ATI drivers. OpenCL implemention for AMD Catalyst
@@ -79,4 +83,5 @@ pkgname = opencl-catalyst
optdepends = opencl-headers: headers necessary for OpenCL development
optdepends = opencl-icd-loader: OpenCL ICD Bindings
provides = opencl-driver
+ conflicts = opencl-amd
diff --git a/PKGBUILD b/PKGBUILD
index 553302b0c4a..f05503430e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ pkgbase=catalyst-utils
pkgname=('catalyst-utils' 'catalyst-libgl' 'opencl-catalyst')
pkgver=15.9
-pkgrel=5
+pkgrel=7
_amdver=15.201.1151
arch=('i686' 'x86_64')
url="http://www.amd.com"
@@ -56,9 +56,9 @@ build() {
package_catalyst-libgl() {
pkgdesc="AMD/ATI drivers. Catalyst drivers libraries symlinks + experimental powerXpress support."
- depends=('catalyst-utils' 'mesa>=10.1.0-4')
- conflicts=('libgl' 'mesa-libgl' 'mesa-libgl-git')
- provides=('libgl' 'mesa-libgl' 'mesa-libgl-git')
+ depends=('catalyst-utils' 'mesa')
+ conflicts=('libgl' 'mesa-libgl' 'mesa-libgl-git' 'libgles' 'libegl')
+ provides=('libgl' 'mesa-libgl' 'mesa-libgl-git' 'libgles' 'libegl')
install=catalyst-libgl.install
install -m755 -d ${pkgdir}/usr/lib/xorg/modules/extensions
@@ -105,6 +105,7 @@ package_opencl-catalyst() {
depends=('gcc-libs')
optdepends=('opencl-headers: headers necessary for OpenCL development'
'opencl-icd-loader: OpenCL ICD Bindings')
+ conflicts=('opencl-amd')
if [ "${CARCH}" = "i686" ]; then