summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelics@felics-tablet2016-03-11 00:34:22 +0100
committerfelics@felics-tablet2016-03-11 00:34:22 +0100
commit46b40738c233f5567a3c068a3fa0a284bbb54911 (patch)
tree2612aec1f16f8ec253d1003126e04a60300055f3
parentd272f74d2d75d52e5b98cabbf88f3af05eb8ea1f (diff)
downloadaur-46b40738c233f5567a3c068a3fa0a284bbb54911.tar.gz
Testing what AUR accepts (lengths of optdepends fields -- it isn't documented!)
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 13 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0bf76f1e1c5..9417e0ab2e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Thu Mar 10 23:28:46 UTC 2016
+# Thu Mar 10 23:34:21 UTC 2016
pkgbase = auto-07p
pkgdesc = Software for continuation and bifurcation problems in ordinary differential equations. Release 07P. Environment variables controlling build (default to 'no', see PKGBUILD): _BUILD_DOC, _WITH_PLAUT04, _PLAUT04_WITH_QT, AUTO_DEBUG, _WITH_OPENMP, _WITH_MPI.
pkgver = 0.9.1
@@ -16,18 +16,6 @@ pkgbase = auto-07p
depends = gcc-fortran
depends = gcc
depends = python2
- optdepends = python2-matplotlib: For python interface.
- optdepends = ipython2: For python interface.
- optdepends = lesstif: For GUI94 and PLAUT04.
- optdepends = openmotif: For GUI94 and PLAUT04. ('openmotif' can be used instead of 'lesstif')
- optdepends = xterm: For PLAUT plotting interface.
- optdepends = soxt: For PLAUT04 plotting interface (enable compilation of 'plaut04' by setting the environment variable '_WITH_PLAUT04' to 'yes').
- optdepends = soqt: For PLAUT04 plotting interface (enable compilation of 'plaut04' by setting the environment variable '_WITH_PLAUT04' to 'yes'). ('soqt' can be used instead of 'soxt'. If using 'soqt', set '_PLAUT04_WITH_QT' to 'yes'.)
- optdepends = coin: For plaut04 plotting interface (enable compilation of 'plaut04' by setting the environment variable '_WITH_PLAUT04' to 'yes').
- optdepends = inventor: For plaut04 plotting interface (enable compilation of 'plaut04' by setting the environment variable '_WITH_PLAUT04' to 'yes'). ('inventor' can be used instead of 'coin', but 'coin' (Coin3D) is recommended due to rendering issues (see AUTO documentation).)
- optdepends = openmpi: For MPI message passing (parallel computation). To build, set the environment variable '_WITH_OPENMP' to 'yes'.
- optdepends = texlive-bin: For compiling the manual (enable compilation of documentation by setting the environment variable '_BUILD_DOC' to 'yes').
- optdepends = transfig: For compiling the manual (enable manual compiling in PKGBUILD (enable compilation of documentation by setting the environment variable '_BUILD_DOC' to 'yes')).
options = libtool
options = staticlibs
source = http://sourceforge.net/projects/auto-07p/files/auto07p/0.9/auto07p-0.9.1.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 54f1766a5a8..9bf3a10926b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -37,18 +37,18 @@ makedepends=(
'gcc'
)
optdepends=(
- "python2-matplotlib: For python interface."
- "ipython2: For python interface."
- "lesstif: For GUI94 and PLAUT04."
- "openmotif: For GUI94 and PLAUT04. ('openmotif' can be used instead of 'lesstif')"
- "xterm: For PLAUT plotting interface."
- "soxt: For PLAUT04 plotting interface (enable compilation of 'plaut04' by setting the environment variable '_WITH_PLAUT04' to 'yes')."
- "soqt: For PLAUT04 plotting interface (enable compilation of 'plaut04' by setting the environment variable '_WITH_PLAUT04' to 'yes'). ('soqt' can be used instead of 'soxt'. If using 'soqt', set '_PLAUT04_WITH_QT' to 'yes'.)"
- "coin: For plaut04 plotting interface (enable compilation of 'plaut04' by setting the environment variable '_WITH_PLAUT04' to 'yes')."
- "inventor: For plaut04 plotting interface (enable compilation of 'plaut04' by setting the environment variable '_WITH_PLAUT04' to 'yes'). ('inventor' can be used instead of 'coin', but 'coin' (Coin3D) is recommended (see AUTO documentation).)"
- "openmpi: For MPI message passing (parallel computation). To build, set the environment variable '_WITH_OPENMP' to 'yes'."
- "texlive-bin: For compiling the manual (enable compilation of documentation by setting the environment variable '_BUILD_DOC' to 'yes')."
- "transfig: For compiling the manual (enable manual compiling in PKGBUILD (enable compilation of documentation by setting the environment variable '_BUILD_DOC' to 'yes'))."
+# "python2-matplotlib: For python interface."
+# "ipython2: For python interface."
+# "lesstif: For GUI94 and PLAUT04."
+# "openmotif: For GUI94 and PLAUT04. ('openmotif' can be used instead of 'lesstif')"
+# "xterm: For PLAUT plotting interface."
+# "soxt: For PLAUT04 plotting interface (enable compilation of 'plaut04' by setting the environment variable '_WITH_PLAUT04' to 'yes')."
+# "soqt: For PLAUT04 plotting interface (enable compilation of 'plaut04' by setting the environment variable '_WITH_PLAUT04' to 'yes'). ('soqt' can be used instead of 'soxt'. If using 'soqt', set '_PLAUT04_WITH_QT' to 'yes'.)"
+# "coin: For plaut04 plotting interface (enable compilation of 'plaut04' by setting the environment variable '_WITH_PLAUT04' to 'yes')."
+# "inventor: For plaut04 plotting interface (enable compilation of 'plaut04' by setting the environment variable '_WITH_PLAUT04' to 'yes'). ('inventor' can be used instead of 'coin', but 'coin' (Coin3D) is recommended (see AUTO documentation).)"
+# "openmpi: For MPI message passing (parallel computation). To build, set the environment variable '_WITH_OPENMP' to 'yes'."
+# "texlive-bin: For compiling the manual (enable compilation of documentation by setting the environment variable '_BUILD_DOC' to 'yes')."
+# "transfig: For compiling the manual (enable manual compiling in PKGBUILD (enable compilation of documentation by setting the environment variable '_BUILD_DOC' to 'yes'))."
) ### Note: Some of these are optional at build time, but once a feature is build in (by './configure' automatically detecting the corresponding libraries), the packages are required to actual run AUTO, so they are _no_ optdepends for the binary package, just for the source.
license=(
'BSD'