summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Shark2020-07-23 15:37:26 +0300
committerAndrew Shark2020-07-23 15:37:26 +0300
commit5b5fb273d400b879f67ceeed729308b0a03ee2a9 (patch)
treec2fd3cc291b72e25c02c6991ec5690c36a4452ac
parent370d39c63ddc0264cc7456f459c83a7611e3499b (diff)
downloadaur-5b5fb273d400b879f67ceeed729308b0a03ee2a9.tar.gz
20.20_1098277-1
-rw-r--r--.SRCINFO71
-rw-r--r--PKGBUILD110
2 files changed, 80 insertions, 101 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97a0397ebe3..a8c55819f09 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = amdgpu-pro-installer
- pkgver = 19.30_934563
+ pkgver = 20.20_1098277
pkgrel = 1
- url = https://www.amd.com/en/support/kb/release-notes/rn-rad-lin-19-30-unified
+ url = https://www.amd.com/en/support/kb/release-notes/rn-amdgpu-unified-linux-20-20
arch = x86_64
groups = Radeon_Software_for_Linux
license = custom: multiple
makedepends = wget
- source = https://drivers.amd.com/drivers/linux/amdgpu-pro-19.30-934563-ubuntu-18.04.tar.xz
- sha256sums = b97f0e31a9ca01971b1855e8e191fa825d538f7941331d3b15bc46474dde50f6
+ source = https://drivers.amd.com/drivers/linux/amdgpu-pro-20.20-1098277-ubuntu-20.04.tar.xz
+ sha256sums = 8c08a8e3b2fc422e94a9b2226e015cfc40606b5e2613c483f9638874ccbfb312
pkgname = amdgpu-core-meta
pkgdesc = Config file /etc/ld.so.conf.d/20-amdgpu.conf
@@ -20,53 +20,60 @@ pkgname = amdgpu-pro-core-meta
install = amdgpu-pro-core-meta.install
arch = any
license = custom: AMDGPU-PRO EULA
- depends = amdgpu-core-meta=19.30_934563-1
+ depends = amdgpu-core-meta=20.20_1098277-1
pkgname = amf-amdgpu-pro
pkgdesc = AMDGPU Pro Advanced Multimedia Framework
license = custom: AMDGPU-PRO EULA
- depends = amdgpu-pro-core-meta=19.30_934563-1
+ depends = amdgpu-pro-core-meta=20.20_1098277-1
depends = gcc-libs
depends = glibc
+ depends = libgl1
depends = libx11
- depends = opencl-amdgpu-pro-orca=19.30_934563-1
- depends = opencl-amdgpu-pro-pal=19.30_934563-1
- depends = vulkan-amdgpu-pro=19.30_934563-1
+ depends = opencl-amdgpu-pro-orca=20.20_1098277-1
+ depends = opencl-amdgpu-pro-pal=20.20_1098277-1
+ depends = vulkan-amdgpu-pro=20.20_1098277-1
pkgname = hip-amdgpu-pro
pkgdesc = HIP-CLANG runtime. HIP-CLANG allows developers to convert CUDA code to common C++
license = custom: AMDGPU-PRO EULA
- depends = amdgpu-pro-core-meta=19.30_934563-1
+ depends = amdgpu-pro-core-meta=20.20_1098277-1
depends = glibc
pkgname = amdgpu-pro-libgl
pkgdesc = AMDGPU Pro OpenGL driver
license = custom: AMDGPU-PRO EULA
- depends = amdgpu-pro-core-meta=19.30_934563-1
+ depends = amdgpu-pro-core-meta=20.20_1098277-1
+ depends = gcc
depends = gcc-libs
depends = glibc
+ depends = libdrm
depends = libx11
depends = libxcb
depends = libxdamage
depends = libxext
depends = libxfixes
depends = libxxf86vm
+ depends = wayland
provides = libgl
- backup = etc/gbm/gbm.conf
+ backup = etc/amd/amdapfxx.blb
pkgname = lib32-amdgpu-pro-libgl
pkgdesc = AMDGPU Pro OpenGL driver (32-bit)
license = custom: AMDGPU-PRO EULA
- depends = amdgpu-pro-core-meta=19.30_934563-1
- depends = amdgpu-pro-libgl=19.30_934563-1
+ depends = amdgpu-pro-core-meta=20.20_1098277-1
+ depends = amdgpu-pro-libgl=20.20_1098277-1
+ depends = lib32-gcc
depends = lib32-gcc-libs
depends = lib32-glibc
+ depends = lib32-libdrm
depends = lib32-libx11
depends = lib32-libxcb
depends = lib32-libxdamage
depends = lib32-libxext
depends = lib32-libxfixes
depends = lib32-libxxf86vm
+ depends = lib32-wayland
provides = lib32-libgl
backup = etc/amd/amdrc
backup = etc/ld.so.conf.d/10-amdgpu-pro-i386.conf
@@ -74,27 +81,32 @@ pkgname = lib32-amdgpu-pro-libgl
pkgname = opencl-amdgpu-pro-comgr
pkgdesc = Code object manager (COMGR)
license = custom: AMDGPU-PRO EULA
- depends = amdgpu-pro-core-meta=19.30_934563-1
+ depends = amdgpu-pro-core-meta=20.20_1098277-1
+ depends = gcc
+ depends = gcc-libs
depends = glibc
pkgname = opencl-amdgpu-pro-dev
pkgdesc = AMD OpenCL SDK
license = custom: AMDGPU-PRO EULA
+ depends = gcc
depends = glibc
+ depends = opencl-amdgpu-pro-comgr=20.20_1098277-1
pkgname = opencl-amdgpu-pro-pal
pkgdesc = AMDGPU Pro OpenCL driver PAL
license = custom: AMDGPU-PRO EULA
- depends = amdgpu-pro-core-meta=19.30_934563-1
+ depends = amdgpu-pro-core-meta=20.20_1098277-1
depends = glibc
- depends = opencl-amdgpu-pro-comgr=19.30_934563-1
+ depends = opencl-amdgpu-pro-comgr=20.20_1098277-1
provides = opencl-driver
backup = etc/OpenCL/vendors/amdocl64.icd
pkgname = opencl-amdgpu-pro-orca
pkgdesc = AMDGPU Pro OpenCL driver ORCA aka legacy
license = custom: AMDGPU-PRO EULA
- depends = amdgpu-pro-core-meta=19.30_934563-1
+ depends = amdgpu-pro-core-meta=20.20_1098277-1
+ depends = gcc
depends = glibc
provides = opencl-driver
backup = etc/OpenCL/vendors/amdocl-orca64.icd
@@ -102,36 +114,29 @@ pkgname = opencl-amdgpu-pro-orca
pkgname = lib32-opencl-amdgpu-pro-orca
pkgdesc = AMDGPU Pro OpenCL driver ORCA aka legacy (32-bit)
license = custom: AMDGPU-PRO EULA
- depends = amdgpu-pro-core-meta=19.30_934563-1
+ depends = amdgpu-pro-core-meta=20.20_1098277-1
+ depends = lib32-gcc
depends = lib32-glibc
provides = lib32-opencl-driver
backup = etc/OpenCL/vendors/amdocl-orca32.icd
-pkgname = roct-amdgpu-pro
- pkgdesc = development environment for hsakmt-roct
- license = MIT
- depends = amdgpu-pro-core-meta=19.30_934563-1
- depends = glibc
- depends = numactl
-
-pkgname = roct-amdgpu-pro-dev
- pkgdesc = development environment for hsakmt-roct
- license = MIT
- depends = roct-amdgpu-pro=19.30_934563-1
-
pkgname = vulkan-amdgpu-pro
pkgdesc = AMDGPU Pro Vulkan driver
license = custom: AMDGPU-PRO EULA
- depends = amdgpu-pro-core-meta=19.30_934563-1
+ depends = amdgpu-pro-core-meta=20.20_1098277-1
+ depends = gcc
depends = gcc-libs
depends = glibc
+ depends = wayland
provides = vulkan-driver
pkgname = lib32-vulkan-amdgpu-pro
pkgdesc = AMDGPU Pro Vulkan driver (32-bit)
license = custom: AMDGPU-PRO EULA
- depends = amdgpu-pro-core-meta=19.30_934563-1
+ depends = amdgpu-pro-core-meta=20.20_1098277-1
+ depends = lib32-gcc
depends = lib32-gcc-libs
depends = lib32-glibc
+ depends = lib32-wayland
provides = lib32-vulkan-driver
diff --git a/PKGBUILD b/PKGBUILD
index 3128ff38784..915f37f41aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,9 @@
# Maintainer: Andrew Shark <ashark @at@ linuxcomp.ru>
# Autogenerated from AMD's Packages file
-major=19.30
-minor=934563
+major=20.20
+minor=1098277
+ubuntu_ver=20.04
pkgbase=amdgpu-pro-installer
pkgname=(
@@ -19,23 +20,21 @@ opencl-amdgpu-pro-dev
opencl-amdgpu-pro-pal
opencl-amdgpu-pro-orca
lib32-opencl-amdgpu-pro-orca
-roct-amdgpu-pro
-roct-amdgpu-pro-dev
vulkan-amdgpu-pro
lib32-vulkan-amdgpu-pro
)
pkgver=${major}_${minor}
pkgrel=1
arch=('x86_64')
-url=https://www.amd.com/en/support/kb/release-notes/rn-rad-lin-19-30-unified
+url=https://www.amd.com/en/support/kb/release-notes/rn-amdgpu-unified-linux-20-20
license=('custom: multiple')
groups=('Radeon_Software_for_Linux')
makedepends=('wget')
-DLAGENTS='https::/usr/bin/wget --referer https://www.amd.com/en/support/kb/release-notes/rn-rad-lin-19-30-unified -N %u'
+DLAGENTS='https::/usr/bin/wget --referer https://www.amd.com/en/support/kb/release-notes/rn-amdgpu-unified-linux-20-20 -N %u'
-source=(https://drivers.amd.com/drivers/linux/amdgpu-pro-${major}-${minor}-ubuntu-18.04.tar.xz)
-sha256sums=(b97f0e31a9ca01971b1855e8e191fa825d538f7941331d3b15bc46474dde50f6)
+source=(https://drivers.amd.com/drivers/linux/amdgpu-pro-${major}-${minor}-ubuntu-${ubuntu_ver}.tar.xz)
+sha256sums=(8c08a8e3b2fc422e94a9b2226e015cfc40606b5e2613c483f9638874ccbfb312)
PKGEXT=".pkg.tar"
@@ -79,7 +78,7 @@ package_amdgpu-core-meta () {
install=amdgpu-core-meta.install
arch=('any')
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/amdgpu-core_${major}-${minor}_all.deb
+ extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-${ubuntu_ver}/amdgpu-core_${major}-${minor}_all.deb
move_copyright
}
@@ -90,16 +89,16 @@ package_amdgpu-pro-core-meta () {
arch=('any')
depends=("amdgpu-core-meta=${major}_${minor}-${pkgrel}")
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/amdgpu-pro-core_${major}-${minor}_all.deb
+ extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-${ubuntu_ver}/amdgpu-pro-core_${major}-${minor}_all.deb
move_copyright
}
package_amf-amdgpu-pro () {
pkgdesc="AMDGPU Pro Advanced Multimedia Framework"
license=('custom: AMDGPU-PRO EULA')
- depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "gcc-libs" "glibc" "libx11" "opencl-amdgpu-pro-orca=${major}_${minor}-${pkgrel}" "opencl-amdgpu-pro-pal=${major}_${minor}-${pkgrel}" "vulkan-amdgpu-pro=${major}_${minor}-${pkgrel}")
+ depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "gcc-libs" "glibc" "libgl1" "libx11" "opencl-amdgpu-pro-orca=${major}_${minor}-${pkgrel}" "opencl-amdgpu-pro-pal=${major}_${minor}-${pkgrel}" "vulkan-amdgpu-pro=${major}_${minor}-${pkgrel}")
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/amf-amdgpu-pro_1.4.12-${minor}_amd64.deb
+ extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-${ubuntu_ver}/amf-amdgpu-pro_${major}-${minor}_amd64.deb
move_copyright
}
@@ -108,7 +107,7 @@ package_hip-amdgpu-pro () {
license=('custom: AMDGPU-PRO EULA')
depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "glibc")
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/hip-amdgpu-pro_${major}-${minor}_amd64.deb
+ extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-${ubuntu_ver}/hip-amdgpu-pro_${major}-${minor}_amd64.deb
move_copyright
}
@@ -116,60 +115,53 @@ package_amdgpu-pro-libgl () {
pkgdesc="AMDGPU Pro OpenGL driver"
license=('custom: AMDGPU-PRO EULA')
provides=('libgl')
- depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "gcc-libs" "glibc" "libx11" "libxcb" "libxdamage" "libxext" "libxfixes" "libxxf86vm")
- backup=(etc/gbm/gbm.conf)
-
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/libegl1-amdgpu-pro_${major}-${minor}_amd64.deb
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/libgbm1-amdgpu-pro_${major}-${minor}_amd64.deb
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/libgbm1-amdgpu-pro-base_${major}-${minor}_all.deb
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/libgl1-amdgpu-pro-appprofiles_${major}-${minor}_all.deb
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/libgl1-amdgpu-pro-dri_${major}-${minor}_amd64.deb
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/libgl1-amdgpu-pro-ext-hwe_${major}-${minor}_amd64.deb
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/libgl1-amdgpu-pro-glx_${major}-${minor}_amd64.deb
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/libglapi1-amdgpu-pro_${major}-${minor}_amd64.deb
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/libgles2-amdgpu-pro_${major}-${minor}_amd64.deb
+ depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "gcc" "gcc-libs" "glibc" "libdrm" "libx11" "libxcb" "libxdamage" "libxext" "libxfixes" "libxxf86vm" "wayland")
+ backup=(etc/amd/amdapfxx.blb)
+
+ extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-${ubuntu_ver}/libegl1-amdgpu-pro_${major}-${minor}_amd64.deb
+ extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-${ubuntu_ver}/libgl1-amdgpu-pro-appprofiles_${major}-${minor}_all.deb
+ extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-${ubuntu_ver}/libgl1-amdgpu-pro-dri_${major}-${minor}_amd64.deb
+ extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-${ubuntu_ver}/libgl1-amdgpu-pro-ext_${major}-${minor}_amd64.deb
+ extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-${ubuntu_ver}/libgl1-amdgpu-pro-glx_${major}-${minor}_amd64.deb
+ extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-${ubuntu_ver}/libglapi1-amdgpu-pro_${major}-${minor}_amd64.deb
+ extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-${ubuntu_ver}/libgles2-amdgpu-pro_${major}-${minor}_amd64.deb
move_copyright
-
- # extra_commands:
- mv "${pkgdir}"/opt/amdgpu-pro/lib/xorg/modules/extensions/libglx-ext-hwe.so "${pkgdir}"/opt/amdgpu-pro/lib/xorg/modules/extensions/libglx.so
}
package_lib32-amdgpu-pro-libgl () {
pkgdesc="AMDGPU Pro OpenGL driver (32-bit)"
license=('custom: AMDGPU-PRO EULA')
provides=('lib32-libgl')
- depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "amdgpu-pro-libgl=${major}_${minor}-${pkgrel}" "lib32-gcc-libs" "lib32-glibc" "lib32-libx11" "lib32-libxcb" "lib32-libxdamage" "lib32-libxext" "lib32-libxfixes" "lib32-libxxf86vm")
+ depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "amdgpu-pro-libgl=${major}_${minor}-${pkgrel}" "lib32-gcc" "lib32-gcc-libs" "lib32-glibc" "lib32-libdrm" "lib32-libx11" "lib32-libxcb" "lib32-libxdamage" "lib32-libxext" "lib32-libxfixes" "lib32-libxxf86vm" "lib32-wayland")
backup=(etc/amd/amdrc etc/ld.so.conf.d/10-amdgpu-pro-i386.conf)
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/libegl1-amdgpu-pro_${major}-${minor}_i386.deb
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/libgbm1-amdgpu-pro_${major}-${minor}_i386.deb
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/libgl1-amdgpu-pro-dri_${major}-${minor}_i386.deb
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/libgl1-amdgpu-pro-ext-hwe_${major}-${minor}_i386.deb
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/libgl1-amdgpu-pro-glx_${major}-${minor}_i386.deb
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/libglapi1-amdgpu-pro_${major}-${minor}_i386.deb
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/libgles2-amdgpu-pro_${major}-${minor}_i386.deb
+ extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-${ubuntu_ver}/libegl1-amdgpu-pro_${major}-${minor}_i386.deb
+ extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-${ubuntu_ver}/libgl1-amdgpu-pro-dri_${major}-${minor}_i386.deb
+ extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-${ubuntu_ver}/libgl1-amdgpu-pro-ext_${major}-${minor}_i386.deb
+ extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-${ubuntu_ver}/libgl1-amdgpu-pro-glx_${major}-${minor}_i386.deb
+ extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-${ubuntu_ver}/libglapi1-amdgpu-pro_${major}-${minor}_i386.deb
+ extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-${ubuntu_ver}/libgles2-amdgpu-pro_${major}-${minor}_i386.deb
move_copyright
# extra_commands:
- mv "${pkgdir}"/opt/amdgpu-pro/lib/xorg/modules/extensions/libglx-ext-hwe.so "${pkgdir}"/opt/amdgpu-pro/lib/xorg/modules/extensions/libglx.so
rm "${pkgdir}"/etc/amd/amdrc "${pkgdir}"/opt/amdgpu-pro/lib/xorg/modules/extensions/libglx.so
}
package_opencl-amdgpu-pro-comgr () {
pkgdesc="Code object manager (COMGR)"
license=('custom: AMDGPU-PRO EULA')
- depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "glibc")
+ depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "gcc" "gcc-libs" "glibc")
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/opencl-amdgpu-pro-comgr_${major}-${minor}_amd64.deb
+ extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-${ubuntu_ver}/opencl-amdgpu-pro-comgr_${major}-${minor}_amd64.deb
move_copyright
}
package_opencl-amdgpu-pro-dev () {
pkgdesc="AMD OpenCL SDK"
license=('custom: AMDGPU-PRO EULA')
- depends=("glibc")
+ depends=("gcc" "glibc" "opencl-amdgpu-pro-comgr=${major}_${minor}-${pkgrel}")
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/opencl-amdgpu-pro-dev_${major}-${minor}_amd64.deb
+ extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-${ubuntu_ver}/opencl-amdgpu-pro-dev_${major}-${minor}_amd64.deb
move_copyright
}
@@ -180,7 +172,7 @@ package_opencl-amdgpu-pro-pal () {
depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "glibc" "opencl-amdgpu-pro-comgr=${major}_${minor}-${pkgrel}")
backup=(etc/OpenCL/vendors/amdocl64.icd)
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/opencl-amdgpu-pro-icd_${major}-${minor}_amd64.deb
+ extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-${ubuntu_ver}/opencl-amdgpu-pro-icd_${major}-${minor}_amd64.deb
move_copyright
}
@@ -188,10 +180,10 @@ package_opencl-amdgpu-pro-orca () {
pkgdesc="AMDGPU Pro OpenCL driver ORCA aka legacy"
license=('custom: AMDGPU-PRO EULA')
provides=('opencl-driver')
- depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "glibc")
+ depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "gcc" "glibc")
backup=(etc/OpenCL/vendors/amdocl-orca64.icd)
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/opencl-orca-amdgpu-pro-icd_${major}-${minor}_amd64.deb
+ extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-${ubuntu_ver}/opencl-orca-amdgpu-pro-icd_${major}-${minor}_amd64.deb
move_copyright
}
@@ -199,28 +191,10 @@ package_lib32-opencl-amdgpu-pro-orca () {
pkgdesc="AMDGPU Pro OpenCL driver ORCA aka legacy (32-bit)"
license=('custom: AMDGPU-PRO EULA')
provides=('lib32-opencl-driver')
- depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "lib32-glibc")
+ depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "lib32-gcc" "lib32-glibc")
backup=(etc/OpenCL/vendors/amdocl-orca32.icd)
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/opencl-orca-amdgpu-pro-icd_${major}-${minor}_i386.deb
- move_copyright
-}
-
-package_roct-amdgpu-pro () {
- pkgdesc="development environment for hsakmt-roct"
- license=('MIT')
- depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "glibc" "numactl")
-
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/roct-amdgpu-pro_1.0.9-${minor}_amd64.deb
- move_copyright
-}
-
-package_roct-amdgpu-pro-dev () {
- pkgdesc="development environment for hsakmt-roct"
- license=('MIT')
- depends=("roct-amdgpu-pro=${major}_${minor}-${pkgrel}")
-
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/roct-amdgpu-pro-dev_1.0.9-${minor}_amd64.deb
+ extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-${ubuntu_ver}/opencl-orca-amdgpu-pro-icd_${major}-${minor}_i386.deb
move_copyright
}
@@ -228,9 +202,9 @@ package_vulkan-amdgpu-pro () {
pkgdesc="AMDGPU Pro Vulkan driver"
license=('custom: AMDGPU-PRO EULA')
provides=('vulkan-driver')
- depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "gcc-libs" "glibc")
+ depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "gcc" "gcc-libs" "glibc" "wayland")
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/vulkan-amdgpu-pro_${major}-${minor}_amd64.deb
+ extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-${ubuntu_ver}/vulkan-amdgpu-pro_${major}-${minor}_amd64.deb
move_copyright
# extra_commands:
@@ -243,9 +217,9 @@ package_lib32-vulkan-amdgpu-pro () {
pkgdesc="AMDGPU Pro Vulkan driver (32-bit)"
license=('custom: AMDGPU-PRO EULA')
provides=('lib32-vulkan-driver')
- depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "lib32-gcc-libs" "lib32-glibc")
+ depends=("amdgpu-pro-core-meta=${major}_${minor}-${pkgrel}" "lib32-gcc" "lib32-gcc-libs" "lib32-glibc" "lib32-wayland")
- extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-18.04/vulkan-amdgpu-pro_${major}-${minor}_i386.deb
+ extract_deb "${srcdir}"/amdgpu-pro-${major}-${minor}-ubuntu-${ubuntu_ver}/vulkan-amdgpu-pro_${major}-${minor}_i386.deb
move_copyright
# extra_commands: